Jump to content
LimeySteve

My latest 02 has a propellor speedometer very wierd

23 posts / 1388 viewsLast Reply

Recommended Posts

I drove my latest 02 to work yesterday to start the tidy up & I have never seen a speedometer do what is on the video , it was very hypnotic !

th_2013-03-09_09-23-15_195_zps4c46452e.jpg

Share this post


Link to post
Share on other sites

show the vid

Share this post


Link to post
Share on other sites

th_2013-03-09_09-23-15_195_zps4c46452e.jpg

Try this it worked at first !

Click on the image it worked for me .

Share this post


Link to post
Share on other sites

sorry my pc freaked out when i click it,btw i sent u a message regarding my dual40'S

Share this post


Link to post
Share on other sites

Thats a sweet mod how much shipped to 55391

Share this post


Link to post
Share on other sites

Steve it was the strangest thing I've seen from a speedo I almost crashed filming with my phone LOL.

Nate, I don't have a cleaner , soak them in a gallon of lacquer thinners , strip & refurb., carb cleaner now is so green it hardly works. I can jet etc as long as you fit a wide band 02 sensor.

Share this post


Link to post
Share on other sites

^10-4 i have allready installed a innovate wide band, the gauge is on mydash thanks.I wish i could see the speedo vid

Share this post


Link to post
Share on other sites

I see the peg is gone already :)

I believe they do that when the magnet thingy is too close to the spinning thingy. Or something. I broke the needle on mine, rather than the peg. In 1986.

;-)

Cheers,

Share this post


Link to post
Share on other sites

Smokin' rockets, Commander, were you driving in hyper-space?

Bob Napier

Share this post


Link to post
Share on other sites

Mine did that before.... The needle snapped when it hit the zero pin, then she really got spinning, and loudly whirring, until the coiled return spring on the inside exploded, and it was basically hosed. Too many broken bits to ever repair. Hooray for parts cars...

Share this post


Link to post
Share on other sites

mine is almost as erratic, i fear it might start to take off soon.

is there a fix for it? i've had the cluster apart already for cleaning.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.