Jump to content
Guest schnelltii

euro turn signals

13 posts / 5841 viewsLast Reply

Recommended Posts

Guest schnelltii

I am trying to install my Euro turn signals but cant get them to work. I noticed on the US version there are two terminals for each wire to go to. On the Euro version there is only one spot for the wire to go to. I tried splicing the wires together, and Ive tried moving one wire to the spring bulb terminals. No go. Am i missing something. Any help would be spectacular!!!!!!!!!!!!!!!! And yes I put the housing back on the fender to make sure it is grounded

Share this post


Link to post
Share on other sites

Euro turn signals are just turn signals, as the parking lights are in the headlights on Euro cars. DO NOT join the two wires together or you'll really mess things up between parking/tail lights and turn signals.

In this case, archives are your friends.

mike

Share this post


Link to post
Share on other sites

My 70 had runnin lights in the euro flats, mounted aft of the turn signal bulb and a very small bulb but they worked, no doubt yours have a mounting hole on the flat piece of the metal that runs the length of the assembly? easy do if not.

Share this post


Link to post
Share on other sites

wired with an extra parking light bulb for the US (only) market. But you're correct, it's easy to add an additional small bulb and holder to a "real" Euro assembly to perform the parking light function.

mike

Share this post


Link to post
Share on other sites
Guest schnelltii

Now that makes sence. So turn signal wire to the single filiment bulb in existing housing....and purchase a small socket and bulb for parking light. Second wire to that. Ground at fender with mounting screws. I guess i didnt realize that euro didnt have parking light in the housing as US did. Thank you for all your help guys. And yes... archive is deff my friend in this!!

Share this post


Link to post
Share on other sites

Justt installed euros on my 71. i had a pair of cracked well worn stock lights and housings that had the 2 wire hook up. the socket for the two wire is soldered to the housing and gentle application of heat from a propane tourch convinced them to literall fall out. next i removed the bulb housing fromt he euro and used a dremel to round out the hole to where the 2 connector would slide in with at tight fit to insure a good ground. jb welded the housing in and now have working turn signals and parks in the euros. PO of the euros had wired in a bulb as described above but it did not create enough light to be noticeable much less get by inspection guru. if a bulb of sufficient potency were wired in without having agood place to rest, it might do to the lense what happens to taillight lenses when the wrong bulb is used, ie melt it.

good luck

Gale H

Share this post


Link to post
Share on other sites

Here are a couple pics of mine..tap light thing was very easy...ten minutes, they were done. Good Luck!

And yes, I cleaned the rust off before I final installed...:-)

IMG_5761.jpg

IMG_5760.jpg

Share this post


Link to post
Share on other sites
I am trying to install my Euro turn signals but cant get them to work. I noticed on the US version there are two terminals for each wire to go to. On the Euro version there is only one spot for the wire to go to. I tried splicing the wires together, and Ive tried moving one wire to the spring bulb terminals. No go. Am i missing something. Any help would be spectacular!!!!!!!!!!!!!!!! And yes I put the housing back on the fender to make sure it is grounded

This thread is the shit!

http://www.bmw2002faq.com/component/option,com_forum/Itemid,57/page,viewtopic/t,268960/highlight,earl+myers/

Share this post


Link to post
Share on other sites

Ziff73, and 71bmr02.

 

Great info. Going to use this method to deal with new euro's, as the PO evidently used similar method to avoid 2nd bulb. This was a link provided to me in my request for help on 8/22/13. Dead on. Thanks guys. FAQ rocks.

 

don

Share this post


Link to post
Share on other sites

Wish I read this thread before I started my conversion. So I decided to just switch the bulb brackets and drill out the 2 piece compression brass rivets from my old American turn signals and the euros. Tried to use aluminum pop rivets to secure the bracket to the lense but realized they won't ground. Looked around for replacement brass rivets but no luck. Any ideas? 

Share this post


Link to post
Share on other sites

schnelltii,

 

Here is what a flush Euro unit looks like with the small running light bulb, i.e., the bulb mentioned by Mike in an aforementioned post, in front of the turn signal bulb.  My unit came this way - two bulbs.  Both bulbs work well and as intended.  

Photo:  the units (might need to be enlarged to see small bulb)

Photo:  installed

 

NOTE:  I used new gaskets.  I had to 3M them into place, tape them in position, and let the 3M do its job for a while in order for the gaskets to be installed.  The final fit was really tight fit 

 

Larry 

 

IMG_3998.thumb.jpg.519d316e28298f3d7ea061a30f89a8ac.jpgIMG_4018.thumb.jpg.8e0acb69b139bcab4b7cc518c2886557.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.