Jump to content
rcraig

Quite possibly a stupid suspension ? but befuddled on this

2 posts / 431 viewsLast Reply

Recommended Posts

So I took out my left rear spring. The rubber bump stop(?) down the center of the spring and attached to the upper perch popped off. There is a dinky ass hole on the top of the rubber bump stop and a big shroom headed stud (like a carriage bolt) it has to go back on. Does not appear the stud comes off. Lube and force won't get this sucker back on it. I've seen pregnancies easier than this. Is it just old and too hard? Heat it up with a heat gun, lube everything up and pray? Most likely I am missing the obvious? I am installing Ireland stage 1 springs so guessing it needs it but no idea how far suspension travel is otherwise I am ok with "You can chuck it"

Thanks,

Robert

69 Chamonix 02[/img][/url]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.