Jump to content

my new '74tii has an APPETITE for fuel


Guest Anonymous
 Share

Recommended Posts

Guest Anonymous

I have jsut got a 1974 2002tii, It seems to run fine and drives really well, my dad drove it for 1600klms and said the economy was good, then when I drive it (city driving) it used 30litres in a week when my old 1984 323i guzzler would have used 15-20ltres with the same amount of driving, and No I didn't totally thrash it ;)

Any help would be great,

Thanks guys,

Link to comment
Share on other sites

Guest Anonymous

test the cold start injector: remove the two socket head cap screws, aim it into a glass jar, plug the hole in the intake manifold and have someone start the car. It may be hard to start without the extra injector, but you should see a temperature-dependent fine mist of fuel for a second or two on start-up, then the fuel mist should stop with no dripping.

Dripping means leaking, and there's your poor fuel economy.

Otherwise, the linkage is suspect, any you'll have to get it right. New pieces are available, as is the gage to set them; also the synchronization between the pump and throttle valve. There's a lot to mess with on a tii, be sure you are capable, and will acknowlege responsibility for your tinkering, or take it to a pro.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Upcoming Events

×
×
  • Create New...