Jump to content

grotflo

Solex
  • Content Count

    336
  • Joined

  • Last visited

  • Feedback

    100%

Community Reputation

86 Excellent

1 Follower

Contact Methods

  • Website URL
    http://www.honrroll.com

Profile Information

  • Gender
    Male
  • Location
    Atlanta, GA

Recent Profile Visitors

4,106 profile views
  1. Beautiful 1973 Verona 2002. I purchased it from Arizona about 3-1/2 years ago and have meticulous receipts totaling over $10k (in parts, my labor was free!). Custom hidden A/C, Bluetooth radio, brand new carpet and sound deadening, new exhaust, W&N high capacity radiator, new brakes/struts/shocks/wheel bearings, rebuilt heater box and valve, rebuilt trunk panels, etc. I recently bought an E39 to shuttle my kids around, so this just isn't getting driven as much as it deserves. Asking $24,500/obo. To view more photos and videos, please see: https://photos.app.goo.gl/iTZqTUZ4SNZWhoCj6 Garrett 724-575-0966
  2. Check my previous post with links to products I ordered. I had leftover MLV and Kilmat when I was finished.
  3. Beautiful spring day in Atlanta.
  4. I’ve got this in my car - hooks into the back of my Blaupunkt Frankfurt. Totally hidden. Automatically connects when your phone starts playing audio. Highly recommend this guy and his product.
  5. Appreciate the advice, I figured the dimmer switch might be the culprit. I'll try cleaning it and see if that fixes it.
  6. Wondering if anyone’s had this problem. When I first start my car and turn on the headlights, the dash lights work fine. After about five minutes, they slowly get dimmer and then stay off. Just affects the gauge illumination - all the other lights (indicator, high beams, oil pressure, etc) work. What could be the cause of this? Even if I dim the lights all the way off and drive like that, after a few minutes they won’t light up.
  7. What are you asking for the under dash covers? Shipped to the US.
  8. My windows aren’t tinted. It was hot. Here’s what I learned though. If I parked in a parking deck during the day (i.e. the interior temp wasn’t too hot), the A/C could keep up and I would stay comfortable on my ride home. But if the car was outside in the sun all day, it couldn’t effectively cool it off. Really depends on where you park and whether or not the 2002 is your primary car. It also cools much better when the car is moving - idling in Atlanta rush hour traffic was not ideal.
  9. Looking for a good transmission for my ‘73. Most important are quiet synchros and bearings, no grinding or crunching, and preferably no leaks. Shipping to 30315. Thanks, Garrett
  10. Wondering if anyone else has had this problem. I've got a stock 4-speed with a pretty new clutch and T/O bearing. When I start the car, it sounds normal, but as the engine and tranny warm up after a few minutes of driving, it makes a rattling noise from what I think is the front of the transmission. Almost like metal balls inside a metal container. When I accelerate, it seems to get mostly quiet (or maybe it's being drowned out by the engine noise). Then when I decelerate (in any gear) between 3500-2000 RPM it makes a loud metallic growling noise. I jacked up the rear and tried to recreate the sound, but it didn't work. It must need the load of slowing down on the driveline. It's only been making this noise for a few weeks. Transmission mount is good, giubo (guibo?) is good, diff and tranny both have fluid, car shifts fine. Other than the noise, all seems to be in order. The only thing I can think of is that several months ago, I swapped in a Wallothnesch upgraded radiator, which is slightly thicker. To get enough clearance for the fan, I pushed the engine and tranny back as far as I could, maybe an additional 1/4". I've read you need to push the diff toward the front of that car, otherwise it will make weird noises, but is it possible to be under too much compression? Or is it just an internal issue with the transmission?
  11. As usual, the FAQ nailed it. Turns out it was nothing more than a loose ground to the engine block. Cleaned it up, tightened up the bolt, and all is good. Sometimes the simplest causes are the most easily overlooked, at least by me. I was going down the mental rabbit hole of bad starter, bad ignition switch, etc. Thanks again for all your advice!
  12. Good question. I don't remember. I'll also check that this evening. But from memory, I don't believe it has an additional grounding point. It has the + to the right post and the - spade connector to the bottom terminal. Is there an additional way to ground it that I missed?
  13. Thanks for the help everyone! I took a quick look again this morning and the + wire from the battery is looking pretty rough, certainly not all the strands are intact. I'm going to swap in a new cable this evening and report back. Fingers crossed it's a two minute fix. Those are the best. Ray gets the award for most accurate assessment of the problem.
  14. Here’s the backstory. This morning, my starter turned over a bit slower than normal, but it started just fine. It’s a Chinese M3 starter clone from eBay. I was leaving work this evening, and it turned over slowly for about a second, then stopped. I thought that maybe it was the battery, so I bought a new one to test. Starter still won’t turn over, although it did make a weird, subtle thump from somewhere the first time I tried. Now the solenoid won’t even click, nothing. Here’s the weird part. My dome light takes about 5 seconds to fade on, but when I turn the key to the on position (not even the start position), the dome light immediately turns off. The gauge cluster lights don’t work now either. What could be the problem? Fuses are all intact, don’t see any loose wires, noting at first glance seems off. The (brand new) battery has 12.6V when the car is off, so I’m assuming that’s not the issue. It’s like the voltage from the battery isn’t getting to the rest of the car.
  15. If they are indeed compatible, I wonder why the outer diameter is so far off then. As the Tire Rack chart shows, the 6.4 tire is 25.2" in diameter. That's considerably larger than the 165 tire, which is 23.4". That would seem to make a big difference to the speedo.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.