• Upcoming Events

gboghosian

front suspenion woes

3 posts in this topic Last Reply

Recommended Posts

I am rebuilding my suspension with urethane bushings. With the control arm bushings in, the control arm/wishbone will not go all the way on to my radius arm/tension strut, even when the inner control arm is pushed in against the mount. With the stock rubber bushings it all fit together, but now, no such luck. Ideas? Suggestions? More pictures? TIA (Yes, I know I have no washers on the control arm bushings, they are in the mail to me)

DSCN6999.JPG

DSCN6998.JPG

click on picture(s) for bigger version

Share this post


Link to post
Share on other sites
Guest

Slide the arm through the front of subframe and outer control arm first, then swing up the inner control arm and connect the inner control arm after the outer side is in. Makes any sense?

626-497-3773

Le

Share this post


Link to post
Share on other sites
Slide the arm through the front of subframe and outer control arm first, then swing up the inner control arm and connect the inner control arm after the outer side is in. Makes any sense?

626-497-3773

Le

I just tried that and it didn't work. I have an eccentric bolt for the inner control arm mount, not a straight bolt. There isn't enough play in the bushings to do that. Thanks for the suggestion though.

gabe

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.