Sign in to follow this  
FunElan

Interesting symptoms

4 posts in this topic Last Reply

Recommended Posts

The car warms up fine on street driving, then on the freeway (sustained 4000rpm), starts to run hot, and the heater blows cold. After slowing down, engine cools, and the heater blows hot.

Ideas?

P.S.- This is the Cabriolet and not my precious Caribe :D

Share this post


Link to post
Share on other sites

Sounds maybe like your heater core is cavitating at higher speeds.

I was told once that you need to purge all the air from the system by jacking up the front of the car while filling with fluid.

Then again if it is running a high temperature with chills it could be the Swine Flu.

post-2154-13667605640489_thumb.jpg

Share this post


Link to post
Share on other sites

Usually you can burp it by letting the engine warm up with the radiator cap loose and the heater control turned to full hot, and watch to see if the coolant level in the radiator drops. If it does, and you have warm air from the heater, then the air bubble has passed and vented out via the open radiator. Add coolant to the proper level and replace the cap.

If that doesn't work, you may have to loosen a heater hose at the heater core (try the outlet hose on the driver's side) and listen for escaping air. When coolant starts to come out, you've got the air purged.

The first method has always worked for me, although sometimes it takes a little driving around the neighborhood to get the coolant circulating before it'll burp.

mike

Share this post


Link to post
Share on other sites
Guest Anonymous
The car warms up fine on street driving, then on the freeway (sustained 4000rpm), starts to run hot, and the heater blows cold. After slowing down, engine cools, and the heater blows hot. Ideas?

Interesting? Huh?

I have never experienced the symptoms you describe in my 02's, nor have I ever needed to purge air from the system. Maybe I am just lucky. I have experienced similar symptoms in other cars though.

Running hot at speed and running cool at idle is a classic symptom of a plugged radiator or plugged hoses. A marginal radiator will conduct enough heat to keep an engine cool when heat transfer demands are low - like idle. Higher engine speeds create more heat and that is where the radiator or other parts of the cooling system truly get get tested. My beater 65 Mustang has done this for years. I am just to lazy to fix it. If the heater is blowing cold - while everything is running hot, seems like a related flow issue. If you think about it, the cavitation theory advanced by others is similar.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this