• Upcoming Events

Sign in to follow this  
2002Targa

Think I might need a new CSB

5 posts in this topic Last Reply

Recommended Posts

Made a helluva racket at about 1800 rpm when the shaft would start banging on the tranny tunnel. Funny though, it only did it between 1800 and 2000. Other than that, I never would have known.

post-67-13667605431773_thumb.jpg

post-67-13667605433832_thumb.jpg

Share this post


Link to post
Share on other sites

that looks like an awful nice work bench you have under that drive shaft....8-|

Share this post


Link to post
Share on other sites

I read on another car board, some guy had a sigline that read:

"You won't have true automotive freedom until you have a true beater"

Share this post


Link to post
Share on other sites

Naw it's still good, just need to repack the bearings ( or repack it WITH some bearings).

Share this post


Link to post
Share on other sites

When I bought my '68 1600, the csb was the first thing I replaced. The PO had wedged-and-wired several short heater hose pieces around the bearing to replace the destroyed rubber. It actually worked fairly well, other than an occasional bang on some bumpy roads - but that may have been the square-light muffler that came on it, too. It would do as a "limp-home" method.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this