• Upcoming Events

4 posts in this topic Last Reply

Recommended Posts

so my 02 s clutch works now and were starting and driving it but it misses above 2200 and when lightly bringing it up in 2nd gear and 3rd gear. i pulled the plugs out and they look like its running lean. but before when i start it cold or hot it run rich. i guess im wondering what jets to run my engine is a m10 with 90mm 9.5:1 pistons and a 292 cam with the tii exhaust manifold. i have followed the tuning with the idle mixture and speed screws with the speed screw in 1/2 turn it runs like crap.

Share this post


Link to post
Share on other sites

Try a set of bigger transition jets- for example, if you have

45's, jump up to 55's.

I had a lot of trouble with this on mine, but many (with the

same jets) haven't...

t

Share this post


Link to post
Share on other sites

like Toby said.

Im running

main 140

idle 55

air correct 175

it seems very good, yet it seems to be different for some cars.

Share this post


Link to post
Share on other sites

Idle 50

Mains 150

Air 185

Pretty stock rebuild and 4000' elevation - runs very well at roughly 13.5 A/F ratio.

Doug

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.