Jump to content
Armond

interior signal flasher miscue

5 posts / 887 viewsLast Reply

Recommended Posts

when I turn right it flashes once or twice then it disappears. Left is o.k. checked the tail lights and both signals lights work but the interior light when I make a right does not. What gives?

Share this post


Link to post
Share on other sites

Check the contacts on the bulb sockets in the rear taillight. You can pull the bulb and clean the center contact. While you're there, bend the contact toward the bulb to make a more positive contact. Also clean the socket with a Scotchbrite pad. On the front indicators, the phillips screws are grounds so make sure the holes they screw into are'nt rusty.

BTW, check ALL your bulbs to make sure they're of the stainless base variety. Sylvania/Osram market a complete line of European bulbs with the proper wattage at your local parts house. These bulbs fit the sockets much better and are more resistant to corrosion. BMW marks each socket with the proper wattage so it's pretty mistake proof. It also makes it easy to make a list for quantities.

Cris

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.