Jump to content
rcf925

Timing Chain Tensioner ?

22 posts / 714 viewsLast Reply

Recommended Posts

(edited)

RELIEF, anybody ever hear rocker hitting valve cover? if I tighten valve cover bolts it hits, If I set cover on loose it's quiet, What the hell, Thought I was going to tear whole motor down again. Anybody see any problems with just using 2 valve cover gaskets? Thanks for everybody's help

Edited by rcf925

Share this post


Link to post
Share on other sites
(edited)

Rockers touching the valve cover with a single gasket is not normal, adding a gasket to fix this is as good as just turning up the radio. You still have a problem. Is there a chance that the valve cover has been cut down?

Edited by Furry Camel

Share this post


Link to post
Share on other sites
(edited)
1 hour ago, Furry Camel said:

Rockers touching the valve cover with a single gasket is not normal, adding a gasket to fix this is as good as just turning up the radio. You still have a problem. Is there a chance that the valve cover has been cut down?

 

It was 1 rocker touching just enough to make a knock, Didnt really leave a mark, I'm running .292 cam with .393 lift so maybe it was just enough to hit. I have another valve cover around, I'll see if it's the same as the one I'm using. I just drove car for about 20 miles, No issues

Edited by rcf925

Share this post


Link to post
Share on other sites

What rocker arms are you running? I’ve had them hit the oil spray bar but that is with a 316 or 336 cam!  If you are hitting with the valve end of the rocker that almost has to be a cam with a ton of metal removed from the base circle of the cam and the oversized adjustment eccentrics adjusted almost all the way down. Unless someone has surfaced the TOP of the head and/or cam cover. 

Share this post


Link to post
Share on other sites

I'm with Byron (Preyupy) there's a fair amount of clearance to the valve cover/rocker, hard to figure whats going on there maybe a valve seat recessed to far into the head or valve lash caps and over sized eccentrics? 

 

Share this post


Link to post
Share on other sites

Cam is brand new IE .292, not reground with IE springs for that cam, , Cam and journals weren't touched, New BMW rockers and eccentrics, shafts, Went together perfect. It may be just valve cover was surfaced for some reason, When I get a chance I'll compare to other one I have. I did measure thickness of head when rebuilding, It had been surfaced, But if I remember it was only minor amount, maybe .005

Share this post


Link to post
Share on other sites

If everything else is fine, then grind away the valve cover where it's hitting, 2 gaskets will probably leak.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.