michael madsen

Retro fit e30 Speedo

7 posts in this topic Last Reply

Recommended Posts

Hi Bimmer  friends, I need help.  I have put a e30 318i speedo cluster in my 02tii because of the 5 speed gearbox from a e30 without mechanical speedometer cabal on, On the diff i have made a tact wheel with the censor. I can only find two connections that has number (31) for the censor on the speedometer and one with (V-). When i turn the diff there is no reading in the speedo? I may be a idiot with electronics, but if i am sure, the speedo does not need power, it only gets its info from the magnetik  reading via the censor.

Can anybody help. 

Many bimmer cheers from Denmark

Share this post


Link to post
Share on other sites

Hi,

 

The e30 diff sensor uses a magnetic reed switch that opens and closes each time the vane goes past.  Check the wiring diagram for the e30 but I believe the reed switch arrangement does indeed require the cluster to be powered up.

Share this post


Link to post
Share on other sites

Thank you for the quick, but as i wrote i know nothing about electronics. I have seen the diagram but tha is the hole instrument, where do i give the speedo 12v? There is only three places i can find on the speedo to put the wire on the diagram : 31B, 31 and v- . So i guess i have to solder the wires to the( Speedo "Solid State" cluster) that says Power input, but i am not sure. Help Help

Cheers from Denmark

Share this post


Link to post
Share on other sites

It looks like the connection to fuse seven which connects to pin 13 at the top of the schematic is the supply. Pin16 at the bottom is the ground. Not that familiar with the nomenclature on the diagram but check whether I am referring to the contact numbers on the plugs rather than any marked connections on the speedo board itself. 

Share this post


Link to post
Share on other sites

Here are photo of the speedo and the three wire stick holes and a video off how i have made the timing tackt wheel and censor. if you look at the photo off the rear of the speedo out left where the board has pice out , you can see five solders: non, 31, 31t,A and a +. Is the + where i solder a 12v to?

Cheers from Denmark

IMG_0143.JPG

IMG_0142.JPG

IMG_0141.MOV

Share this post


Link to post
Share on other sites

Hi,

 

I thought you were using the entire cluster, not just the speedo.  I see now what you are looking for.

 

Do you still have the complete cluster?  If you do, power it up and see which of these speedo pins shows 12 volts.  If you don't have the cluster, your guess as to the + terminal being the correct one is a good place to start.  I suggest providing it 12 volts using a current limited power supply.  Those are the ones that have a control knob not only for the voltage but also for the maximum current that can be drawn.  That way, you will have some protection for your speedo in case that's the wrong terminal.

 

BMW wiring diagrams won't get into component level schematics so you will have to trace things out yourself.  Alternatively, post this on an e30 forum as they may be more familiar with it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now