Hodgepodge

Quiz of the day....

6 posts in this topic Last Reply

Recommended Posts

Hey,  Got two things I'm curious about.  Youguys like quizes, right? 

 

First is this thing I found wedged under a motor mount.    It is about an inch across.  Any idea what it is?  

SCH_5913-14.thumb.jpg.3e16c46d998deeafca40b2c8a309d666.jpg

 

Second...since we're talking about oil leaks today...

When I pulled the exhaust manifold, all of the nuts came off except the top nut on the number 4 cylinder.  Instead, the stud backed out.  I am replacing all the studs, so I didn't thilnk anything of it....until today when I noticed oil leaking from the empty stud hole. In this image the stud hole is a little out of focus, but you can still see a little oil weeping out of it. If I recall correctly, these studs go through into the valve area, so since the engine was tilted and the front end was up high, it is logical to assume that some oil spilled out through the stud hole, correct?      

 

 

SCH_5915s.thumb.jpg.aa6048d7dc5e734f70bc9185fded233e.jpg

  

I have since put the stud back in and cleaned up a little.   I'll put a dab of loctite on the studs I put back in so they don't thread in too far or bottom out at the thread shoulders.

 

Thanks for your response and have a great weekend! 

Share this post


Link to post
Share on other sites

Accelerator pump diaphragm probably from a downdraft Weber, as stated above.

Share this post


Link to post
Share on other sites

Pump diaphragm looks like it’s from a Solex.

Share this post


Link to post
Share on other sites
42 minutes ago, Tdh said:

Pump diaphragm looks like it’s from a Solex.

 

Aaaa....I would say Solex as well, but you know what they say about those pump diaphragms:  they all look the same....  😋

 

Best regards,

 

Steve

 

Share this post


Link to post
Share on other sites

Although I obviously don't recognize the part, I'm going to guess Solex.  Given the interesting things that the PO did with this car, he probably took it apart, got in too deep and then just had the current Weber installed.

 

Thanks!   

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now