Jump to content
Fatherof3

E-brake with E21 rear brakes

9 posts / 581 viewsLast Reply

Recommended Posts

Is the stock e-brake handle the correct leverage ratio for E21 brakes?

The rear brake components all appear fairly new but when I pull my e-brake handle there is not a gradual feeling of it cinching up. The handle pulls fairly free until it stops more abruptly than any e-brake I have used

and the real problem is it's not holding the car.

Share this post


Link to post
Share on other sites

Stock '02 cables will work with only a small mod and won't cost you $60..

 

Please see mlytle's comment at the end of this thread:  

 

Share this post


Link to post
Share on other sites

+1 on 2002 turbo parking brake cable. It's what I did when I went with the e21 rear drums. Think I got it from Rogerstii possibly Blunttech. 

 

Also consider the Paul Cain parking brake upgrade. Bought from coupeking. Think they are presently out of stock.

 

My ebrake is solid and has a good feel to it. 

Share this post


Link to post
Share on other sites
(edited)

I'll look into those previous write ups.

 

The cables that are in there are to long. I had to put spacers behind the adjusting nuts on the handle. 

With the car on jack stands and the wheels turning I adjusted the cables until I heard the shoes starting to drag. Then pulling the handle it comes up less than 30 degrees and tightens up firm but when test driving there is almost no slowing or holding effect.

Edited by Fatherof3

Share this post


Link to post
Share on other sites

The stock rear brakes on mine work just like that... (like sh!t), in spite of being adjusted at the cables/shoes.

I am guessing glazed shoes are my problem... but I dunno.

Mike has the same problem with his and in a weird way, that makes me feel a little better.

Maybe I should keep a cheater bar under the seat, to get some real leverage on the handle ;) 

Share this post


Link to post
Share on other sites
42 minutes ago, Fatherof3 said:

 there is almost no slowing or holding effect.

 

31 minutes ago, '76mintgrun'02 said:

I am guessing glazed shoes are my problem

 

 

Yeah, the parking brake on the '02s sucks but you should definitely be able to hold the car with it on.

 

Leaking wheel cylinder?  Glazed pads/drums? Worn p-brake/shoe components?  If you can draw the cable tight with the lever and you can still roll the car, it doesn't sound like replacing the cables is the answer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.