Jump to content
ymanchik

Fixed Camber plate doesn't fit Strut Bearing

4 posts / 344 viewsLast Reply

Recommended Posts

Working on my front end and ran into a problem. The fixed camber plates don't fit my strut bearing, it's just a tiny bit off. I was planning on drilling out the hole a little bigger to accommodate it. But figured I better ask to see if I'm missing something before I do that. Anyone have any suggestions/tips? Thanks.

IMG_6085.JPG

IMG_6086.JPG

Share this post


Link to post
Share on other sites

I had similar problems when I installed mine. I just used a rat-tail file to hog out the needed space. 

Share this post


Link to post
Share on other sites

Yep, open up a tiny bit as needed.

 

An interesting note, the fixed plates fit cleanly over the old OEM 2002 strut mounts (and you'll note they fit perfectly in the holes on the body).  Several years ago BMW superseded the 2002 strut mount with the E21 strut mount.  They are very very close, but as you found, the hole spacing is not identical.

Share this post


Link to post
Share on other sites
6 hours ago, 2002Scoob said:

I had similar problems when I installed mine. I just used a rat-tail file to hog out the needed space. 

Good to hear, I'll do the same. Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.