Jump to content
burndog

Turbo Performance question inside

18 posts / 1249 viewsLast Reply

Recommended Posts

(edited)

For all of you performance guru's out there, I have a question.

 

As I continue to dial in my EFI / Turbo setup I am reaching higher boost ranges and power. I am now running a smooth powerband range all the way up to 18PSI around 4800 RPM.

 

But twice in the past two days during testing I have noticed that in 4th gear under full throttle and boost I get a sudden "poof", a stutter like the engine cuts out, a little puff of sooty / rich smoke get back on the throttle and everything is fine.

 

Thoughts? Anyone ever experience anything like this and have a possible remedy?

 

It seems to me like the internal wastegate is opening wide open and dumping all my boost pressure and then the motor falls on its face due to the timing and fuel for said RPM / AFR.

 

BURNDOG

Edited by burndog

Share this post


Link to post
Share on other sites

Do you have logging capability? Did you see a sudden drop in manifold pressure on a gauge? Is there a chance that your blow off valve is leaking and/or just opened under load? How is your waste gate controlled, By the ECU or a stand alone pressure regulator? It might be possible that at 18 psi you have so much back pressure it is pushing the internal wastegate valve open, what is the closing pressure on the spring? What ECU are you running? What are you using for a load sensor (MAFor MAP sensor) are you running closed loop on your O2 sensor?

Share this post


Link to post
Share on other sites

 

 

logging capability

This.

 

One of the (many) reasons EFI and turbos work better- you can log 'em.

 

t

Share this post


Link to post
Share on other sites

Also, how are you controlling fuel, rpm, afr and what?  Need a third element.

Share this post


Link to post
Share on other sites

Sorry, Megasquirt MS3x EFI/ECU; EGO, AFR, MAP controls, using sequential ignition and injection. Funny, I have figured out how to do almost everything in Megasquirt except log and analyze.

 

I have been watching / learning from the "SloppyMechanic" online / youtube. His approach and experience is the only thing that has gotten me this far...

 

Crazy fun learning and making more and more power with subtle tweaks.

 

Cheers,

Share this post


Link to post
Share on other sites

Conkitchen,

 

MS3X has automated tunerstudio into an "Autotune" feature. I do not think you can use MS3X tune files in tunerstudio any longer... I will research.

 

I am not so much concerned about the tune, as it runs AWESOME! It runs a little rich (larger injectors) intentionally, so to not lean out and blow

 

I think it is more to do with the blow off valve and the wastegate operation.

Share this post


Link to post
Share on other sites

Is your wastegate simply spring actuated or is it vacuum/electric solenoid assist? In my diesel-powered vehicles running spring/vacuum assist wastegates they usually start to chirp or shutter before they blow open and dump boost -- but then go back closed and happens typically so quickly that engine can "catch" before loosing all rpm/power, and this at times at 75-80 psi. What tells your wastegate to open??

From Galaxy S6

Share this post


Link to post
Share on other sites

Possible spring/vacuum sylenoid is failing. I have a 7.3 in my fleet that appears to be doing same. I would think that unit is plenty stout coming from an industrial diesel. Sounds a little strange but look into the Banks actuator. Much more stout and fast acting than the stock. They might have a relatively cheap fix.

From Galaxy S6

Share this post


Link to post
Share on other sites

Do you have a manual boost controller in your system? Or is the boost limit solely controlled by the MS? Is it possible your boost is spiking and then the MS is shutting it down to prevent detonation?

Share this post


Link to post
Share on other sites

MS is not controlling boost, yet. All manual, I tried a manual boost controller today and it didn't seem to do anything. So, I think I have narrowed it down to the turbo boost actuator being bunged up. Will replace actuator with a Banks or a Turbosmart actuator.

Share this post


Link to post
Share on other sites

hee hee... why does a Banks part on a 2002 seem like putting oranges in your swimming pool?  Pistacios in your socks?  Cauliflower in your check book?

 

Just not something you'd think to do...

 

t

 

who agrees, sounds like binding in your boost regulation circuit- as you've added pressure to boost boost, you're also adding friction. 

 

t

Share this post


Link to post
Share on other sites

 

 

I have been watching / learning from the "SloppyMechanic" online / youtube. His approach and experience is the only thing that has gotten me this far...

 

 

What videos did you find useful? Were they tuning videos? I watched a few but they were mostly just showing built cars, doing burnouts, or street/dyno pulls

 

It'd be nice to find some good tuning videos to help me with my microsquirted M10.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.