Sign in to follow this  
Guest Anonymous

pressing on brake increases idle

7 posts in this topic Last Reply

Recommended Posts

Guest Anonymous

a strange phenomenon indeed. i have a '73 tii and the harder i press on the brake pedal, the higher the idle speed goes up. i've checked the one way valve from the intake plenum and that seems ok. i suppose the brake booster is next to look at, but are those things serviceable at all? they seemed sealed up. thanks!

Share this post


Link to post
Share on other sites
Guest Anonymous

Just sharing some trivia.

Share this post


Link to post
Share on other sites
Guest Anonymous

My 72tii had the same problem it would go up a couple of hundred rpm's when the brakes were pumped. I replaced that valve and hose coming from the intake plenum and it seemed to fix the problem. I think the main problem I had was the hose (it was rock hard with tiny cracks). Hope this helps.

Sean

Share this post


Link to post
Share on other sites
Guest Anonymous

it's not more than a few hundred rpm, but definitely noticeable -- probably more than normal. i'll try replacing the booster hose to see if it helps matters. thanks for all of your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this