Sign in to follow this  
Guest Anonymous

Update: 74tii problem

5 posts in this topic Last Reply

Recommended Posts

Guest Anonymous

Many thanks to Keith, Pikachu, Rey and others for valued insight into my 74tii's problem with hesitation in the power band. My mechanic found that there was indeed a vacuum leak in the decel valve. As the general consensus of the group was to ditch the smog stuff (no emissions testing in Texas), that's what my mech. did. As also suggested, I kept my distributor. As it turns out, Mike Perkins (mechanic) has one of the Bosch distributor machines, and rebuilt my distributor with new bushings, etc., and adjusted the curve for optimal performance. He also found a leak in the vacuum retard dashpot, and replaced it. So now I have a rubber plug in the big hole on the intake, the decel valve is gone, and the small vacuum still runs directly from the intake into the new vacuum retard on the distibutor. THANKS ALL!! Now it runs even better than before this trouble occurred!

Share this post


Link to post
Share on other sites
Guest Anonymous

There isn't a greater sound than a fine tuned 02, but when the kookofish purrs, that is just ... ecstasy.

Thanks for the follow up , we will all benefit

Share this post


Link to post
Share on other sites
Guest Anonymous

Thanks for posting the follow-up

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this