Jump to content

Car will crank but won't start after Carburetor


Henrywy

Recommended Posts

Hi so i went and tried to rebuild a Weber 32/36 DGAV carb as it was leaking fuel. Its a 75 BMW 2002 mostly stock with an electric ignition. Car did run before rebuild. Now when I turn the key it just keeps cranking. Theirs fuel in the bowl of the carb. I dont think the carb getting fuel is the problem. but I do think it's the carb because it ran before but wont now. Spark plugs distributor are all fairly new.

 

Thanks Henry

Link to comment
Share on other sites

I would confirm whether or not that you are getting fuel to the cylinders, either a visible spray into the throttle body with gas peddle being depressed, or have someone crank the engine and spray starting fluid into the carb to see if it fires. Be careful of back flash if doing this.

Maybe some detail of what you did or did not do to your carb durning your "rebuild" would be helpful. And make sure your fuel filter/filters are new.

Use the search function, select google search, and type in something basic like carb rebuild won't start, or your carb type, ECT...

Link to comment
Share on other sites

I found out the hard way that it's not only possible but very easy to reinstall the venturi (the tapered cylinder that fits inside the carburetor throat) backwards.  If you do that, no gas will flow from the jets into the spray nozzle (not the accelerator pump nozzle, this one's part of the venturi) so no gas gets to the engine.  

 

Try spraying some starting fluid down the carb throat while someone cranks the engine (don't lean over the carb while doing this in case there's a backfire).  If it then starts, and you get a squirt of fuel out the accelerator pump nozzle when you work the accelerator linkage, I'd suspect an incorrectly installed venturi.  Let us know whatcha find...

 

cheers

mike

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Upcoming Events

×
×
  • Create New...