Jump to content

Megajolt Installed, Now The Tach Reads 500 Rpm Low...


chrisrouse

Recommended Posts

Hello 02 peeps,

 

I finished my megajolt install over the weekend (car runs like the wind!) and just hooked up the tach circuit, but the tach reads low. I've tried substituting several different value resistors with no real change. Any suggestions? This is the circuit I used:

 

tach diode fix.jpg

 

I've tried with and without the resistor after the diodes. The tach only works with the resistor to ground installed, and has no noticeable change with or without the resistor in series to the tach. The resistor I've tried different values on is the resistor to ground. Values I've tried are 100k, 10k, 1k. Maybe I should go the opposite way? 1M perhaps?    

 

Thanks,

Chris

Link to comment
Share on other sites

Well, that was the first thing that I tried.

 

I will double check my wiring ant try again, but I fail to understand why there would be so much information on tach adapter circuits and even a tach adapter IC offered if the solution were so simple. Maybe i'll be surprised.

 

Then again, I'm powering the coil pack from the original coil wire (due to simplicity of installation) and NOT from the coil power pin on the megajolt. I have a 6 fuse car and with driving lights and a stereo installed, my sources of key-on power are fewer and more precious than with the later 12 fuse cars. Perhaps this approach renders the tach out pin useless?

 

Thanks. 

Link to comment
Share on other sites

I thought the same as you;it really is that easy. The megajolt gets its rpm signal from the crank sensor/trigger wheel. It generates a pulse that replicates that of the coil triggering. It should work regardless of how the coil is wired

Also stock coil wire is not thick enough for the additional juice needed by the new coil

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

  • Upcoming Events

×
×
  • Create New...