Jump to content
clovold

New to 2002, acceleration stumbling issue on 74

3 posts / 295 viewsLast Reply

Recommended Posts

I'm new to 2002s, so please bear with me. I recently got a neglected but running '74 2002. It starts and idles great, runs great except that it stumbles if I try to accelerate abruptly. If I just push the pedal down a little I can get going fine, but all the way down will run like crap. The accel pump works, I can see gas squirt out if I pump the gas pedal.

I think it has a Weber 38/38 carb, right? It also has a new fuel pump.

If this was the vacuum advance I would typically have idle issues, wouldn't I?

Any help greatly appreciated!

Craig L.

Share this post


Link to post
Share on other sites

How neglected is the ignition system? Might be vacuum advance, but I'd review plugs, points, cap and wires first.

Share this post


Link to post
Share on other sites

compression readings

ignition timing set using a timing light

points ? DWELL reading ? electronic ?

..........................................................................................

your description IS classic bad accelerator pump

failure 0 and of the injector nozzle is spraying

poorly and or at the wrong spot down in the throat..........

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.