Jump to content
MikeWooldridge

Finally got out for a drive

4 posts / 454 viewsLast Reply

Recommended Posts

After being without electricity for 94 hours due to ice and 8 inches of snow, I finally was able to get the tii clone out for a good drive. I am still impressed with the engine from Marshall's rust bucket. I do believe it runs better and faster than the '74 tii I had. Maybe it's the lighter weight, but this thing will run. Thanks to Marshall and Jim for all your help. I still have to deal with a noisy throw-out bearing, but all other issues have been addressed.

Hope you all have a great new year.

Happy 02ing, and "drive it like you stole it!"

Share this post


Link to post
Share on other sites

Mike are you bringing this car to MidAmerica? Would love to see it in person since I have followed the story

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.