Jump to content
baller908790

Installed momo hub. Horn not working

5 posts / 2641 viewsLast Reply

Recommended Posts

I just installed a new momo hub and

momo steering wheel. My car is a

74 so I cut off the extra horn wires

and used the plunger? off the old

steering wheel. My hub looks like

this with the plunger installed.

pics11709026.jpg

Share this post


Link to post
Share on other sites

plunger probably not contacting the horn ring.

did the horn work before the swap?

with the horn switch out, will horn sound if you ground the wire to the steering column.

and a simple question....is the ignition switched "on" when you try the horn?

Share this post


Link to post
Share on other sites

So this is the hub with the plunger installed

IMG_4126.jpg

This is the steering wheel with the horn installed

IMG_4113.jpg

IMG_4114.jpg

If I do this with the car on the horn will go off. Completing the circuit?

IMG_4121.jpg

I took this off the brand new momo hub to install the plunger from the old steering wheel

IMG_4122.jpg

Old steering wheel plunger with extra wires

IMG_4123.jpg

This is the steering shaft

IMG_4120.jpg

And this is the hub installed

IMG_4112.jpg

What Am I doing wrong here?

Share this post


Link to post
Share on other sites
plunger probably not contacting the horn ring.

did the horn work before the swap?

with the horn switch out, will horn sound if you ground the wire to the steering column.

and a simple question....is the ignition switched "on" when you try the horn?

The horn worked before the swap. I'll test to see if the horn will sound by grounding it to the steering column.

Share this post


Link to post
Share on other sites

Ok got it working now. There was a bit

of grim on the plunger and contact ring.

Sanded them down with some 320 grit

and buttoned everything up and it now works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.