Jump to content
LeeMW

Electrical problem 2002TII 1972

6 posts / 643 viewsLast Reply

Recommended Posts

Battery or its connections first. The alternator idiot light is not fused.

Share this post


Link to post
Share on other sites

Did this just happen all of a sudden or were you working on something when it happened?

I rewrapped the wire harness on my 72 tii last week and had the same symptoms i forgot to reconnect all the wiring to the alternator and that solved the problem,

Make sure that wiring is secure and clean

Share this post


Link to post
Share on other sites
I just purchased the car and found out about it when I drove it at night.

With the car off and battery disconnected, Remove the plastic cover from the fuse box, remove the fuses, sand the brass contacts, inspect the fuses very closely and re-install if they appear OK.

If the plastic cover for the fuse box is missing, then the contacts and fuses will corrode quicker (than if the cover is installed).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.