Jump to content

Duals rebuilt/installed, mech. adv. dist installed, probs...


Guest Anonymous
 Share

Recommended Posts

Guest Anonymous

Rebuilt and installed my dual Dellorto 40 DHLAs. Took alot of time/patience/care when rebuilding.

Also installed a Bosch JF4D4 mech. adv. dist. also, it looked new inside w/new cond. and new points. I have since found out the dist. is for a 1502.

The trouble: I have runaway idle. It idles around 1300 and then if you touch the throttle, it climbs on it's own to meltdown rpm (I shut it off)

I have the idle adjustment jets at less than the supposed starting point (1.5 vs. 2.5 turns) so I don't think they are a prob, but ?

What I think/hope: either the advance on the dist is weak springed for my application and it launches toward redline, or my float adjustment is out in one or both carbs causing extra fuel to dump into the carb and as rpm climbs the vaccume opens it up and sucks more in a viscious cycle.

What do you think? Anyone run into simular problems?

I'm trying to get it on the road and tested out by June 7th for the Hotsprings run in Arkansas.

Any help/ideas are greatly appreciated as always,

Thanks,

Britt

71 Atlantik (gonna be turbo someday)

Link to comment
Share on other sites

Guest Anonymous

Check to make sure the linkage isn't holding the carbs open slightly, and that the return spring is returning them all the way closed.

Link to comment
Share on other sites

Guest Anonymous

your linkage is binding and you need a stronger return spring. might also be out of sync. need a sync tool like one from unisyn or sk.

Link to comment
Share on other sites

Guest Anonymous

your linkage is binding and you need a stronger return spring. might also be out of sync. need a sync tool like one from unisyn or sk.

if you are close to toronto, bring it over i'll give you carbs the proper tuning it needs.

Link to comment
Share on other sites

Guest Anonymous

supposed to have 4 lbs pressure, so i counted on 3, and what i got was 5.5 which was too damn much.

i got a regualtor and turned it down and things are down to "regular" tuning now.

Thanks again for the help. Should be hell on wheels when sorted, feels strong.

Added a Crane Hi-6 just for kicks also... : )

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Upcoming Events

×
×
  • Create New...