Jump to content

help. misfire at steady (3200 rpm


Guest Anonymous
 Share

Recommended Posts

Guest Anonymous

my 76 has developed a random condition which im calling a misfire at any steady speed thats above 3200 rpm. it has a webber 32/ 36 and petronix was recently installed but didnt cure the problem. its fine when accelerating through this range, and it does it even when cold or hot.

its becoming more prevalent now and i could use some help diagnosing it.

TIA

Link to comment
Share on other sites

Guest Anonymous

vac advance diaphragm. As my late father-in-law used to say, "when you see hoofprints, think horses, not zebras." Unless you're on the Serengeti plains, of course...

Mike

Link to comment
Share on other sites

Guest Anonymous

You can also check to see if you have a vacuum leak at one of the intake runners (where it meets the head). A fouled plug can cause it, but like mike said, check the basics first.

Good Luck,

Mike (#87)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Upcoming Events

×
×
  • Create New...