Jump to content

Red "L" light glows dimly while driving. Fix enclo


Guest Anonymous
 Share

Recommended Posts

Guest Anonymous

This last weekend I took "Sunny" out for some exercise. Out on the freeway I notice the charge light glowing dimly. Off the freeway and into town, the charge light goes out. Around town, all normal. Back on the freeway charge light comes back on. WTF.

I make my list of stuff to check. Battery is very new and charged as it cranks the motor right over. Cables were new and clean. Gotta be a loose ground. The alternator ground wire was on my list of things to replace anyway.

I stick my head under the car and gee, the 3 pin connector on the back of the alternator had backed out. In my haste to rebuild the car for the last 02 Fest, I had not installed the wire retaining clip.

I love these easy fixes that cost nothing. (Except a little pride)

Steve J

72 tii Verona

88 M3 Hennarot

(with more miles than the 02)

Link to comment
Share on other sites

Guest Anonymous

Steve,

I have a similar situation. My charge light comes on around 4,000rpm. I suspected a loose fan belt but tightening this had no impact at all. I'll check my connections now to see if your solution might help.

Regards,

James

'74 2002tii

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Upcoming Events

×
×
  • Create New...