Jump to content

lngbrd
 Share

Recommended Posts

I cannot seem to get the gas fumes out of the car. I replaced the rubber filler connector, the old one did have a crack, so I thought that would solve the problem. I've replaced the fuel pump and the rubber hoses that lead to the carb. I also replaced the hoses from the fuel filter to the carb. The smell doesnt seem like its coming from the engine compartment. What do I look now?

Surfs up in Texas,

lngbrd

Link to comment
Share on other sites

I did all of the usual things mentioned in this thread to cure the gas smell. Turned out the 90 degree elbow nipple coming out of the tank had cracked. Luckily, it was still attached to the tube... Regardless, it's totally unprotected (arguably a worse situation with the OEM boards in the trunk).

After repair I fashioned a collar/standoff to protect it to prevent a repeat occurrence.

Coincidentally, this cured a hard starting problem I was having as well. I love the two for one repairs.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...