Jump to content

14th Annual SoCal Vintage BMW Meet 2021! “All couped up”

Registration is still open. Rally from NorCal is scheduled for Friday. Post your event photos.

SoCal Vintage is Here! 

Post your photos!

battery or alternator??


MrSharky
 Share

Recommended Posts

so - driving Betty today, the "L" light came on but I kept going - and then we shut her off to take some pictures. Got back in, and she wouldn't turn over, had to roll start her. Then she ran fine... came to an intersection, and she died completely.. just plain shut off. Couldn't roll start, and no one around that would jump her (thanks cop) so we got her towed home. Jump started just fine, and no L light. So... knowing the L light is something like, "low charge to battery" (thanks CD) do I suspect the battery or the alternator? Or maybe something else??

Matt

Link to comment
Share on other sites

The brushes in your alternator have worn down and you're driving right off the battery so you lose ignition once the battery level is low enough. Basically you need to replace the alternator. If you swap to a more modern one, it has an easily removable regulator with the brushes attached.

Link to comment
Share on other sites

Thanks for all the input. I put in a new Diehard, and it seems to be much better now. The L light still comes on occasionally and flickers, but stays off for most of the time. Still looking into it - the belt's tight, going to check wires & grounds tomorrow. Maybe put a fancy new alternator on my Xmas wishlist.

Matt

Link to comment
Share on other sites

check the wires where they come out of the alternator connector-

I've had them break there before, and then vibration makes and breaks the contact.

But if it were me, I'd put a meter on it and keep an eye on it starting about yesterday.

Because the brushes in the alternator are a good guess, as are the points

in an old mechanical voltage regulator, and both of those things

are going to get worse, not better.

don't get stranded,

t

Link to comment
Share on other sites

Thanks for all the input. I put in a new Diehard, and it seems to be much better now. The L light still comes on occasionally and flickers, but stays off for most of the time. Still looking into it - the belt's tight, going to check wires & grounds tomorrow. Maybe put a fancy new alternator on my Xmas wishlist.

Matt

You can get a rebuilt 80 AMP alternator w/ an on-board regulator for $80/$85 on flebay, should that be the issue.

Put a volt meter on the output of the generator and see what you get for voltage when the car is running. I believe it should be over 13V.

Link to comment
Share on other sites

Okay - so the light's still on, on more than it's off in fact. Good news is that I do have a voltmeter - but.. where to put it? I'm not sure what the regulator looks like, or where it's located, or where to put the probes... can anyone help (maybe even with pictures??)

Matt

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...