Jump to content

14th Annual SoCal Vintage BMW Meet 2021! “All couped up”

Registration is still open. Rally from NorCal is scheduled for Friday. Post your event photos.

SoCal Vintage is Here! 

Post your photos!

High oil pressure on new engine.


mp1k3
 Share

Recommended Posts

Hello Everybody, I have a little problem with a new engine. When I first start it up the oil pressure is 100 lbs. If I rev the engine too much the oil filter seal will burst. If I let it idle for a few minutes the pressure drops to 80 lbs and all is fine. Any ideas?

Link to comment
Share on other sites

First off, your new engine won't be new very long revving it when cold. This is for the same reason your oil pressure is high at startup- cold oil is too thick. The high pressure indicates it's too thick to pump properly, and regardless it's not doing any lubricating whatsoever. Revving the engine in that condition is causing excessive wear.

Second, what oil are you using (brand and grade)?

Link to comment
Share on other sites

I recall the same symptoms when doing bearings, oil pump and rings on the Tii. Believe I had the oil pressure relief valve spring backwards which consistently blew the filter gasket and made quite a mess. You'll need to drop the pan and pull the oil pump to see if this is the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...